PDA

View Full Version : copy and paste problem in firefox



Jebus
10-14-2005, 05:58 PM
I've been having this weird problem with firefox since yesterday. I can't seem to paste anything into the address bar. I can't copy and paste anything in this forum either. I tried opening up IE and it worked there. I opened notepad and it worked there too. Seeing how those two worked, I copied something from notepad and I was able to successfully paste it into a message box in this forum using firefox. Then I typed random stuff in the message box once again and I successfully copied and pasted it inside the box. It seemed to be working so I tried to paste something in the address bar and it didn't work again. After that, I tried pasting the same thing in the forum's message box but this time it didn't work. So it seems as if every time I click on the address bar, my computer loses memory of what I copied earlier. What could be the problem? Any solutions?

EDIT: another thing is that I can't copy and paste anything from any web page once I click on the address bar. I only get my copy and paste capabilities back when I open up notepad and copy something from there.

the_offsprings_monkey
10-14-2005, 06:01 PM
Yes I also find that I cannot scroll with FireFox ATM, I don't know why but I'm like just using the mans version that is Internet Explorer for now, but I would like to use my geeky student browser as well *sigh*

Endymion
10-14-2005, 11:24 PM
geeky student browser?

anyway... does it not copy with ctrl+c or with right-click>copy? if you do both of those, can you paste into notepad? are there problems copy/pasting into all text boxes or just the address bar? have you installed any extensions recently? go to about:config and check the bolded lines (those are the ones that are not browser-default). see if any of them involve copying or pasting.

Sunny
10-14-2005, 11:30 PM
i have the same problem. in response to your questions, endy..

'anyway... does it not copy with ctrl+c or with right-click>copy?'

doesn't copy with either

'if you do both of those, can you paste into notepad? '

no

'are there problems copy/pasting into all text boxes or just the address bar?'

all text boxes


'have you installed any extensions recently?'

nope

go to about:config and check the bolded lines (those are the ones that are not browser-default). see if any of them involve copying or pasting.

no.

rah.

Jebus
10-14-2005, 11:49 PM
Yes, I use both Ctrl+C plus right-click>copy and it doesn't work with any of those. Hmm.. It seems that I could copy and paste within the text box and notepad but only things that I type. I can't copy and paste things from web pages like text from the news section of offspring.com though. If I try copying something I typed in the text box and paste it into the address bar, nothing happens. I recently updated firefox to 1.0.7 a few days before I had the problem so I haven't I had a chance to reinstall my extensions yet. I just checked a second ago if I had any and I found something called "new.net quick search." I don't recall installing it so I just unistalled it. I see a few bold lines but I don't see any involving copy and paste.

Endymion
10-15-2005, 01:05 AM
it seems to be a known issue in 1.0.7:
https://bugzilla.mozilla.org/show_bug.cgi?id=305032
https://bugzilla.mozilla.org/show_bug.cgi?id=308211
https://bugzilla.mozilla.org/show_bug.cgi?id=309102
https://bugzilla.mozilla.org/show_bug.cgi?id=309179
https://bugzilla.mozilla.org/show_bug.cgi?id=309762
https://bugzilla.mozilla.org/show_bug.cgi?id=309943
https://bugzilla.mozilla.org/show_bug.cgi?id=309944
https://bugzilla.mozilla.org/show_bug.cgi?id=310423
https://bugzilla.mozilla.org/show_bug.cgi?id=310878
https://bugzilla.mozilla.org/show_bug.cgi?id=311078
https://bugzilla.mozilla.org/show_bug.cgi?id=311368
https://bugzilla.mozilla.org/show_bug.cgi?id=312051

my guess is that there will be a 1.0.8 out soon, that's a rather severe usability issue. i'm not seeing it myself... but i think i'm actually using 1.5beta2.

Jebus
10-15-2005, 01:25 AM
I see... I'll have to try the beta version then.

Endymion
10-15-2005, 01:36 AM
i still love our avatars.

Jebus
10-15-2005, 01:39 AM
I'm also having difficulties with winamp. It won't allow me to fast forward through wmv files anymore and it plays them badly. I know that's also a new bug but I just felt like mentioning it because my two favorite programs suck now.

EDIT:

i still love our avatars.
When you're ready, send the pm and we'll switch.

Paint_It_Black
10-15-2005, 02:15 AM
Clint pwns Chuck.

bluefudge
10-15-2005, 04:49 AM
And, Yeah... Firefox just lagga and stuff.. use explorer

Jebus
10-15-2005, 12:22 PM
lagga??????

T-6005
10-15-2005, 12:24 PM
From context, I'm assuming that's a bad thing.

notoriousdoc
10-15-2005, 12:33 PM
Opera pwns all the other explorers sorry asses

Endymion
10-15-2005, 12:55 PM
Opera pwns all the other explorers* sorry asses
*browsers

and yes, opera is a very good browser. i prefer epiphany myself, with its python interactive prompt plugin and all.

Jebus
10-16-2005, 01:54 AM
I was right about to post an update on my problem because copy and paste started to work fine after I installed the beta version. Then I had to copy and paste some text and it stopped working again. While typing, I discovered another bug. Everytime I press the apostrophe key, it opens up the find toolbar. Another thing is that the arrow keys wont let me move around the text.

Endymion
10-16-2005, 02:19 AM
Everytime I press the apostrophe key, it opens up the find toolbar.

the apostrophe is one of the 'key' buttons to begin find-as-you-type. i don't recall off hand how to change key bindings.

as for arrows, works for me... i also can copy/paste still...

one of the bugs (that was marked as a dupe, i believe) said something about a full/overfull cache being the cause. try clearing your cache and see if that helps.

Jebus
10-16-2005, 02:37 AM
I just reinstalled 1.0.7 seeing how 1.5 caused more problems. Clearing the cashe did not help.

Endymion
10-16-2005, 02:45 AM
you can go to 1.0.6 if you want, it should be on their ftp.

Jebus
10-16-2005, 03:08 AM
Nope, didn't work. *sigh*

Endymion
10-16-2005, 03:15 AM
the original bug report was about multiple instances of firefox and stuff... like if you run it once, then open a new window then copy/paste/select all, etc stop working.

does the copy/paste not work if it's a fresh start of firefox after a reboot (check taskmanager to be sure it isn't loading for some reason at boot).

Jebus
10-16-2005, 03:43 AM
nah, firefox wasn't open at startup. It still didn't work even though I only opened it once.

This is strange. I found a way to get around the bug. First I just have to highlight the text. Then move the pointer directly on the address bar so it turns into that "I" shape. Then ctrl+C and quickly click on the address bar so it highlights the address. Then quickly ctrl+v. This works only if you do it quickly.

Jebus
10-20-2005, 10:32 PM
So I found out the solution. Remember when I mentioned that I found a new.net extention that I didn't remember isntalling? It turns out that was the problelm. According to that thread, real player is now bundled with it. Chances are I got it from real player. The internet was hell without copy and paste.
http://forums.mozillazine.org/viewtopic.php?t=330825&start=0

Sunny, check if that was the problem.