PDA

View Full Version : Frustrating iTrip Problem



endlesst0m
07-24-2007, 03:59 PM
I've had an iTrip for about 6 months now, and I've never been able to get it to work out of both speakers in my car. Is that just how it is, and there's nothing I can do about it? I'm fucking tired of only hearing one of the guitar parts whenever I play a song. Sometimes, in certain songs where the guitar intro is designed to play out of only one side, I can't even hear that the song began until the other instruments kick in on the other speakers. It just seems so stupid that there's an expensive product you can buy that won't even allow you to hear crucial things such as the lead guitar. What the fuck can I do? I can't even find anything about it when I search it on Yahoo.

P.S. I don't have a cassette player, so don't bother suggesting to buy that kind of iTrip.

Edit: http://www.space2shop.com/iTrip_Auto_p/9501-tripcbl.htm <This is the kind I have.

endlesst0m
07-24-2007, 04:40 PM
Damn...no one has even clicked this yet, and it's been like 45 minutes. Damn.

Mannen som blev en gris
07-24-2007, 05:11 PM
... why Yahoo?

Revolver-2005?
07-24-2007, 05:50 PM
Don't complain,

1. You didn't lose your iPod
2. You have money to buy shit like iTrip

Rag Doll
07-24-2007, 08:07 PM
i dont have that problem on mine. you're talking about the fm transmitter, right? try it on a stereo in your house. it might just be your car. mine is a little staticy but thats it.

0r4ng3
07-24-2007, 08:23 PM
It could be the iPod, too. When my most recent one was on its way out, the first (and only, actually) thing to go was the headphone jack, so I could never hear out of the right headphone.

Endymion
07-24-2007, 11:25 PM
mine does stereo just fine.

sKratch
07-24-2007, 11:36 PM
Auxiliary input is infinitely superior, but you need a jack on the stereo to do that.

endlesst0m
07-25-2007, 10:03 AM
i dont have that problem on mine. you're talking about the fm transmitter, right? try it on a stereo in your house. it might just be your car. mine is a little staticy but thats it.
http://www.space2shop.com/iTrip_Auto_p/9501-tripcbl.htm <This is the kind I have.

Mine plugs in, so I don't think I can even try it on a stereo inside my house. Also, when I play CD's in my car, both sides of speakers work, so I don't think that's the problem either.

sKratch
07-25-2007, 01:22 PM
I'd say it's most likely a problem with either the ipod's headphone jack, or the jack on the itrip. But wait, itrips plug into the proprietary jack on the bottom of the ipod, not the headphones, right? So then I don't know...

endlesst0m
07-25-2007, 03:31 PM
I guess I'll just try it out in someone else's car so I'll know if the problem lies with my head unit/speakers, or the iPod.

neocon58
07-25-2007, 08:33 PM
I'll tell you how I fixed my Itrip.

I took it back to the store and didn't purchase another.

endlesst0m
07-25-2007, 10:28 PM
Yeah, seriously...

Update: I tried the thing in someone else's car(with thier iPod), and it didn't work there either. So the problem has to be with the iTrip itself. Furthermore, I talked to someone who said thier friend has the same problem I do.

What version of iTrip (or similar product) do you guys use?

Endymion
07-25-2007, 11:26 PM
i have this (http://www.amazon.com/Maxell-Digital-Transmitter-Model-191204/dp/B000T5UKM4/ref=sr_1_48/105-7961231-6911601?ie=UTF8&s=home-garden&qid=1185431115&sr=8-48). it works good. it don't work with new ipods. penis.